Skip to main content
Version: 1.3.0

Kubeslice Controller

Note that the information provided on this page represents the minimum requirements for installing the product. It is essential to understand that these requirements may vary depending on the specific workload of each customer. However, following these minimum requirements will ensure a successful installation of the product.

Cluster Requirements1 Kubernetes Cluster
Node RequirementsKubeSlice needs at least two nodes each with a minimum of 4 vCPUs and 16GB of RAM. We highly recommend creating a separate NodePool for KubeSlice components to improve performance and simplify management.
Supported Kubernetes Versions1.26 and 1.27
Supported Kubernetes ServicesAzure Kubernetes Service (AKS), AWS Elastic Kubernetes Service (EKS), Google Kubernetes Engine (GKE), and Rancher Kubernetes Engine (RKE)
Required Helm Version3.7.0

Kind Clusters

The following are the infrastructure requirements to install KubeSlice components.

info

If you are on Ubuntu OS, then it is recommended to increase the ulimit to 2048 or unlimited.

If you still face issues, see errors due to too many open files.

Host RequirementsMinimum of 8vCPUs and 8GB of RAM
info

Ensure to modify the memory and CPU usage allowed to docker as described in
https://docs.docker.com/desktop/windows/#resources.

info

KubeSlice has been tested on AKS, GKE, and EKS, but it should run in any Kubernetes environment with the supported Kubernetes versions.

info

In an intra-slice scenario, a single cluster can serve as both a controller cluster and a worker cluster. This allows KubeSlice to segment the cluster into application slices. This enables you to better manage and isolate your applications, improving the overall efficiency and performance of your cluster.